中年プログラマーの息抜き

ブログをはじめました。気の向くままにプログラム関連ネタをメモしていきます。

CISCO 841M 設定:15:IPV6(DS-LITE)を試してみた

f:id:tm-b:20170728004131j:plain

IPV6DS-LITE

とりあえず、つながるところまで

ipv6 unicast-routing
ipv6 cef
bridge irb
bridge 1 protocol ieee
bridge 1 route ip

interface Tunnel1
ip address 192.0.0.2 255.255.255.252
tunnel source GigabitEthernet0/5
tunnel destination [AFTRのIPv6アドレス]
tunnel mode ipv6
tunnel path-mtu-discovery

interface GigabitEthernet0/5
no shutdown
ipv6 address autoconfig default
ipv6 enable
ipv6 dhcp client pd PREFIX
bridge-group 1

interface Vlan1
ipv6 address PREFIX ::1/64
ipv6 enable
ipv6 nd other-config-flag
ipv6 dhcp server STATELESS
bridge-group 1

ipv6 dhcp pool STATELESS
import dns-server
import domain-name

no ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Tunnel1
ip route 0.0.0.0 0.0.0.0 Dialer1  ← いらないはずだが、いる

少し問題

ipv6非対応のサイトが通信できてなかったので、Dialer1 の静的ルートも残したままになっています。V4とV6の共存でV4カプセルを自動で作ってくれるのかと思ったのですが、なんかうまくいっていないようで、上の設定だと「V6はTunnel1」「V4はDialer1」を通過している気がします。 また時間を見つけて試してみようかな。。[AFTRのIPv6アドレス]が違うのか、追加したルートが違うのか、なんでしょうねぇ・・・

WPF双方向データバインディング  INotifyPropertyChangedとメソッド置換で遊んでみた

f:id:tm-b:20200929012602j:plain

 

はじめに

INotifyPropertyChangedとメソッドを動的に置き換えて遊んでみました。業務でこんなことすると怒られます。というか動作保証できないし(汗) シュミで遊ぶときはこんな部品があっても良いかな。。。(最適化すると動かないけど)

 

INotifyPropertyChangedを実装する方法

単に何も考えず実装するとこんな感じかな。

・ViewModelプロパティ定義

 private string bindText1 = "";
 public string BindText1 {
      get { return this.bindText1; }
      set {
          this.bindText1 = value;
          NotifyPropertyChanged();
      }
 }

趣味プロで実装するとこんな感じかな(笑)
・ViewModelプロパティ定義

 public string BindText1 { get; set; }

・ViewModelクラスの親クラス

まとめ

好きこそものの上手なれ。 やればできそう、というようなことも会話で役に立つかもしれませんし、時間を見つけていろいろ遊んでみたいと思いますー

 

Joke-INotifyPropertyChanged-Implementが間違ってました。動くもので修正